Forum

Build failed at webruntime

#1

WARNING: webruntime-68.0.3440.106-32-r13 do_fetch: Failed to fetch URL git://github.com/webosose/v8;destsuffix=git/src/v8;protocol=ssh;name=v8, attempting MIRRORS if available
ERROR: webruntime-68.0.3440.106-32-r13 do_fetch: Fetcher failure: Fetch command export DBUS_SESSION_BUS_ADDRESS="unix:abstract=/tmp/dbus-QNTjjZqS3S"; export SSH_AUTH_SOCK="/run/user/1001/keyring-LQRj9c/ssh"; export PATH="/home/ian/project/ose/build-webos/meta-webosose/meta-webos/scripts:/home/ian/project/ose/build-webos/oe-core/scripts:/home/ian/project/ose/build-webos/BUILD/sysroots/x86_64-linux/usr/bin/arm-webos-linux-gnueabi:/home/ian/project/ose/build-webos/BUILD/sysroots/raspberrypi3/usr/bin/crossscripts:/home/ian/project/ose/build-webos/BUILD/sysroots/x86_64-linux/usr/sbin:/home/ian/project/ose/build-webos/BUILD/sysroots/x86_64-linux/usr/bin:/home/ian/project/ose/build-webos/BUILD/sysroots/x86_64-linux/sbin:/home/ian/project/ose/build-webos/BUILD/sysroots/x86_64-linux/bin:/home/ian/project/ose/build-webos/oe-core/scripts:/home/ian/project/ose/build-webos/bitbake/bin:/usr/local/sbin:/usr/local/bin:/usr/sbin:/usr/bin:/sbin:/bin:/usr/games:/usr/local/games:/home/ian/jdk1.8.0_77/bin"; export HOME="/home/ian"; LANG=C git -c core.fsyncobjectfiles=0 clone --bare --mirror ssh://github.com/webosose/v8 /home/ian/project/ose/build-webos/downloads/git2/github.com.webosose.v8 --progress failed with exit code 128, output:
Cloning into bare repository '/home/ian/project/ose/build-webos/downloads/git2/github.com.webosose.v8'...
Host key verification failed.
fatal: Could not read from remote repository.

Please make sure you have the correct access rights
and the repository exists.

ERROR: webruntime-68.0.3440.106-32-r13 do_fetch: Fetcher failure for URL: 'git://github.com/webosose/v8;destsuffix=git/src/v8;protocol=ssh;name=v8'. Unable to fetch URL from any source.
ERROR: webruntime-68.0.3440.106-32-r13 do_fetch: Function failed: base_do_fetch
ERROR: Logfile of failure stored in: /home/ian/project/ose/build-webos/BUILD/work/raspberrypi3-webos-linux-gnueabi/webruntime/68.0.3440.106-32-r13/temp/log.do_fetch.24801
ERROR: Task (/home/ian/project/ose/build-webos/meta-webosose/meta-webos/recipes-webos/chromium/webruntime.bb:do_fetch) failed with exit code '1'
NOTE: Tasks Summary: Attempted 1172 tasks of which 1121 didn't need to be rerun and 1 failed.
NOTE: Writing buildhistory
NOTE: Writing buildhistory took: 0.8828983306884766 seconds
NOTE: Build completion summary:
NOTE: do_populate_sysroot: 0.0% sstate reuse(0 setscene, 13 scratch)

Summary: 1 task failed:
/home/ian/project/ose/build-webos/meta-webosose/meta-webos/recipes-webos/chromium/webruntime.bb:do_fetch
Summary: There was 1 WARNING message shown.
Summary: There were 3 ERROR messages shown, returning a non-zero exit code.

I tried twice and it failed at the same location. Any advise would be appreciated.

0 Likes

#2

As i heard, #56 build version is not stable to build, so they roll-back to #55 build.
You can re-clone and build it after removing current repo (build-webos).

0 Likes

#3

Thanks @nicolas. I finally got the build working. I think the problem is related to ssh key authentication. I re-started from another directory. It completed the webos-image build.

0 Likes