Fetching error


WARNING: libmpc-native-1.0.3-r0 do_fetch: Failed to fetch URL tar.gz, attempting MIRRORS if available
WARNING: libxml2-native-2.9.4-r0 do_fetch: Failed to fetch URL;name= libtar, attempting MIRRORS if available
WARNING: libpcre-native-8.39-r0 do_fetch: Checksum mismatch for local file /home/rahul/work/rpi/webos/build-webos/d ownloads/pcre-8.39.tar.bz2
Cleaning and trying again.
WARNING: libpcre-native-8.39-r0 do_fetch: Renaming /home/rahul/work/rpi/webos/build-webos/downloads/pcre-8.39.tar.b z2 to /home/rahul/work/rpi/webos/build-webos/downloads/pcre-8.39.tar.bz2_bad-checksum_38c9404978ad5a353452e0d2284b2 b90
WARNING: libpcre-native-8.39-r0 do_fetch: Checksum failure encountered with download of http://downloads.sourceforg - will attempt other sources if available
WARNING: libconfig-1.5-r0 do_fetch: Failed to fetch URL, a ttempting MIRRORS if available
WARNING: glibmm-2.44.0-r0 do_fetch: Failed to fetch URL 44.0.tar.xz, attempting MIRRORS if available
WARNING: gnutls-3.3.27-r0 do_fetch: Failed to fetch URL z, attempting MIRRORS if available
ERROR: gnutls-3.3.27-r0 do_fetch: Fetcher failure: Fetch command export PATH="/home/rahul/work/rpi/webos/build-webo s/meta-webosose/meta-webos/scripts:/home/rahul/work/rpi/webos/build-webos/oe-core/scripts:/home/rahul/work/rpi/webo s/build-webos/BUILD/sysroots/x86_64-linux/usr/bin/arm-webos-linux-gnueabi:/home/rahul/work/rpi/webos/build-webos/BU ILD/sysroots/raspberrypi3/usr/bin/crossscripts:/home/rahul/work/rpi/webos/build-webos/BUILD/sysroots/x86_64-linux/u sr/sbin:/home/rahul/work/rpi/webos/build-webos/BUILD/sysroots/x86_64-linux/usr/bin:/home/rahul/work/rpi/webos/build -webos/BUILD/sysroots/x86_64-linux/sbin:/home/rahul/work/rpi/webos/build-webos/BUILD/sysroots/x86_64-linux/bin:/hom e/rahul/work/rpi/webos/build-webos/oe-core/scripts:/home/rahul/work/rpi/webos/build-webos/bitbake/bin:/home/rahul/b in:/home/rahul/.local/bin:/usr/local/sbin:/usr/local/bin:/usr/sbin:/usr/bin:/sbin:/bin:/usr/games:/usr/local/games: /snap/bin"; export HOME="/home/rahul"; /usr/bin/env wget -t 2 -T 30 -nv --passive-ftp --no-check-certificate -P /ho me/rahul/work/rpi/webos/build-webos/downloads ‘’ --prog ress=dot -v failed with exit code 4, output:
–2018-03-20 10:52:07--
=> ‘/home/rahul/work/rpi/webos/build-webos/downloads/gnutls-3.3.27.tar.xz’
Resolving (…
Connecting to (||:21… connected.
Logging in as anonymous …
Error in server response, closing control connection.

–2018-03-20 10:52:10--
(try: 2) => ‘/home/rahul/work/rpi/webos/build-webos/downloads/gnutls-3.3.27.tar.xz’
Connecting to (||:21… connected.
Logging in as anonymous …
Error in server response, closing control connection.
Giving up.

ERROR: gnutls-3.3.27-r0 do_fetch: Fetcher failure for URL: ‘ ar.xz’. Unable to fetch URL from any source.
ERROR: gnutls-3.3.27-r0 do_fetch: Function failed: base_do_fetch
ERROR: Logfile of failure stored in: /home/rahul/work/rpi/webos/build-webos/BUILD/work/raspberrypi3-webos-linux-gnu eabi/gnutls/3.3.27-r0/temp/log.do_fetch.23942
ERROR: Task (/home/rahul/work/rpi/webos/build-webos/meta-webosose/meta-webos/recipes-upstreamable/gnutls/gnutls_3.3 failed with exit code ‘1’

I am getting the error when running the command “make webos-image” and build env is ubuntu 16.04 LTS


I don’t have a build environment handy right off at the moment, but that seems to indicate that the ftp server is not acting right, may be temporarily down, or maybe the files have moved.

It does seem that they do have it available via https at … so changing the file source might be a good option, if that FTP failure isn’t a transient failure that has been fixed already.


Also, further looking, I see that you had several fetch failures – is it possible the internet connection went down briefly?


This is solution


Yes. that’s correct and you can use the link instead of ftp…