Forum

Build configuration problem with icecc version

Hi,

I have a warning below while I run ./mcf

2020-01-20T09:56:13 INFO __main__ MCF-6.2.3: Updating build directory
2020-01-20T09:56:13 INFO __main__ Checking for local changes in [bitbake]
2020-01-20T09:56:13 INFO __main__ [bitbake] is up-to-date.
2020-01-20T09:56:13 INFO __main__ Checking for local changes in [oe-core]
2020-01-20T09:56:14 INFO __main__ [oe-core] is up-to-date.
2020-01-20T09:56:14 INFO __main__ Checking for local changes in [meta-oe]
2020-01-20T09:56:14 INFO __main__ Updating [meta-oe]
2020-01-20T09:56:14 INFO __main__ Done updating [meta-oe]
2020-01-20T09:56:14 INFO __main__ Checking for local changes in [meta-updater]
2020-01-20T09:56:14 INFO __main__ [meta-updater] is up-to-date.
2020-01-20T09:56:14 INFO __main__ Checking for local changes in [meta-virtualization]
2020-01-20T09:56:14 INFO __main__ [meta-virtualization] is up-to-date.
2020-01-20T09:56:14 INFO __main__ Checking for local changes in [meta-qt5]
2020-01-20T09:56:14 INFO __main__ Updating [meta-qt5]
2020-01-20T09:56:14 INFO __main__ Done updating [meta-qt5]
2020-01-20T09:56:14 INFO __main__ Checking for local changes in [meta-webosose]
2020-01-20T09:56:14 INFO __main__ Updating [meta-webosose]
2020-01-20T09:56:14 INFO __main__ Done updating [meta-webosose]
2020-01-20T09:56:14 INFO __main__ Checking for local changes in [meta-raspberrypi]
2020-01-20T09:56:14 INFO __main__ [meta-raspberrypi] is up-to-date.
2020-01-20T09:56:14 INFO __main__ Checking for local changes in [meta-security]
2020-01-20T09:56:14 INFO __main__ [meta-security] is up-to-date.
2020-01-20T09:56:14 INFO __main__ Repo Update Summary
2020-01-20T09:56:14 INFO __main__ ===================
2020-01-20T09:56:14 INFO __main__ No local changes found
./mcf:252: DeprecationWarning: The 'warn' method is deprecated, use 'warning' instead
  "http://wiki.lgsvl.com/pages/viewpage.action?pageId=96175316")
2020-01-20T09:56:14 WARNING __main__ WARNING: Wrong icecc package version 1.2-1 is installed, disabling build from using ICECC.
Please check 'How To Install ICECC on Your Workstation (Client)'
http://wiki.lgsvl.com/pages/viewpage.action?pageId=96175316
2020-01-20T09:56:14 INFO __main__ MCF-6.2.3: Configuring build directory BUILD
2020-01-20T09:56:14 INFO __main__ MCF-6.2.3: Done configuring build directory BUILD
./mcf:798: DeprecationWarning: The 'warn' method is deprecated, use 'warning' instead
  logger.warn('No mirror for github.com was detected, please define mirrors in ~/.gitconfig if some are available')
2020-01-20T09:56:14 WARNING __main__ No mirror for github.com was detected, please define mirrors in ~/.gitconfig if some are available
2020-01-20T09:56:14 INFO __main__ Done.


icecc --version
ICECC 1.3.90

any suggestion ?

Hi,
For about icecc and mirror warnning message, you can ignore because you didn't configure them and that's no matter. go ahead next step :slight_smile:

2 Likes