Ares-install error

everytime I try to install ipk file on my virtualbox emulator.
it gives me this error all the time.
please help.

what else should I consider?

1 Like

Hi @miiiiiin, welcome to the forum.

  • What is the version of your CLI?( ares --version)
  • Could you explain the steps to reproduce your case?


cli version: 2.4.0

steps to reproduce:

  1. execute npm run pack -p
  2. ares-package dist
  3. ares-install com.gbg.smartcane_1.0.0_all.ipk (webos is running on the virtualbox machine)

but if I get a dist folder from one of my team mates. it works. I think the error is being made when I execute "npm run pack -p"

1 Like

This probably is not the problem related to CLI (because you succeeded using the teammate's dist)

Check the following things:

  • Compare your dist folder with that of your teammates.

    There might be differences, such as hierarchy or something.

  • Check the package.json

    Check the difference between pack of yours and teammate's.

You've confirmed that the package.json files are the same, but there are differences in the dist folder. You've also tried rebuilding with the enact pack command to ensure the same folder structure, but you're still encountering the same error. Are there any other possible solutions for this?

In that case, the IPK file and dist directory are needed for debugging.

If you don't mind sharing the files, please send the files to


I've sent the files, including the mentioned ones, via email. Please confirm.

I checked the email you sent.
I'll inform you as soon as the analysis is done.