<update manifest file failed>

ares-install ERR! [com.webos.appInstallService failure]: luna-send command failed

Is this error different from your other post?

yeah im getting same error in ose cli as well

Could you describe the steps you've taken?

built ipk using ares commands and then tried to install it , this error popped


Did you do the following procedures before using TV/OSE CLI?

What you have to check are as follows:

Check the version of CLI

areas -v
  • If you get 1.xxxx, you are using TV's CLI.
  • If you get 2.xxx, you are using OSE's CLI.

Verify the previous CLI is deleted COMPLETELY

Case 1. TV > OSE

  1. Delete the TV's CLI (Go to the directory you've installed, delete the whole directory)
  2. Restore environment variables you set: Restore env. variables referred in the Step 3. Configure the environment variables.
  3. Install the OSE's CLI

Case 2: OSE > TV

  1. Delete TV CLI using npm uninstall -g @webosose/ares-cli
  2. Install the TV's CLI.

If the same error occurs even though you do the steps correctly, please send the whole logs and output of ares -v .