How to use Japanese Virtual Keyboard


Could anyone tell me how to enable Japanese Virtual Keyboard?

The Japanese Virtual Keyboard is mentioned in 2.1.0 release notes: .
However my 2.1.0, 2.2.0 and 2.3.0 builds do not show Japanese or 日本語 entry in
Settings > General > Language > Keyboard Languages list.

Thanks in advance.

Hi @ryoon , welcome to the forum!

For now, Japanese VKB cannot set by GUI.

You can add Japanese VKB by luna call as follows:
(below example adds English and Japanese VKB)

luna-send -n 1 luna://com.webos.service.settings/setSystemSettings '{"settings": {"localeInfo": {"locales": { "UI": "en-US"}, "keyboards": [ "en", "ja" ] } } }'

Then if you execute any VKB, you can type the Japanese.

(No changes in Settings > General > Language > Keyboard menu.)


1 Like

Thanks for you explanation!
I will try to enable with the command.

Thanks again.