Forum

LS2 TTS service does not work in Enact app(raspberrypi4)

I am trying to use LS2 TTS service using LS2Request that Enact framework provides. But, no matter how I implement it, I cannot get any response from the request.
Under is my code and appinfo.json configuration


Also, I tried using "readAlert", which Enact framework provides, It shows that "Platform Doesn't support TTS Api". But TTS service works fine using LS2 API on terminal.

Hi Mooyaho,
using console.log print the error message. if it is showing below error then it is ACG permission issue..

{returnValue: false, errorCode: -1, errorText: "Denied method call "speak" for category "/""}

if you install the IPK with required permissions in the appinfo.json then it should work.. if it is not working then please check with coreOS team.

Thanks,
Muniraju

I found typo in your code
in appinfo.json file,
"tts.managment" --> "tts.management"

I cannot receive neither success nor failure response. I got the required permissions via "ls-monitor -i com.webos.service.tts" command, which is "tts.managment" and "tts.operation".

I have tried both "tts.managment" and "tts.management". Neither didn't worked.

Can you share the application and IPK.. and one more question do other services working fine or not in the enact application.

if not working then check with below plain code this code provided by web Engine

var bridge = new WebOSServiceBridge();
    var url = 'luna://com.webos.service.systemservice/clock/getTime';
    var params = '{}';

    function callback(msg){
        var arg = JSON.parse(msg);
        if (arg.returnValue) {
            webOSSystem.PmLogString(6, "GETTIME_SUCCESS", '{"APP_NAME": "example web app"}', "UTC : " + arg.utc);
        }
        else {
            webOSSystem.PmLogString(3, "GETTIME_FAILED", '{"APP_NAME": "example web app"}', "errorText : " + arg.errorText);
        }
    }

    bridge.url = url;
    bridge.onservicecallback = callback;
    bridge.call(url, params);

you can refer Developing Built-in Web Apps | webOS Open Source Edition for more info