Python error while setting up enviornment

I just tried to setup a webOS OSE environment.
However i am getting one annoying error after 'make webos-image'
Log data follows:
| DEBUG: Executing python function sysroot_cleansstate
| DEBUG: Python function sysroot_cleansstate finished
| DEBUG: Executing shell function autotools_preconfigure
| DEBUG: Shell function autotools_preconfigure finished
| DEBUG: Executing python function autotools_copy_aclocals
| DEBUG: Python function autotools_copy_aclocals finished
| DEBUG: Executing shell function do_configure
| ERROR: Cannot use 'python', Python 2.6 or later is required.
| Note that Python 3 or later is not yet supported.
| Use --python=/path/to/python to specify a supported Python.
| WARNING: exit code 1 from a shell command.
| ERROR: Function failed: do_configure (log file is located at /home/vaishali/RPI/webosose/build-webos/BUILD/work/x86_64-linux/qemu-native/2.7.0-r1/temp/log.do_configure.19706)
ERROR: Task (virtual:native:/home/vaishali/RPI/webosose/build-webos/oe-core/meta/recipes-devtools/qemu/ failed with exit code '1'

Any one got this ?
It says to set up --pyhton , but does not specify when. While making image or duginr ./mcf ?

what is your os environment?

I attempted to hundreds of times making webos image during 2 weeks and finally find out it is only came out in native Ubuntu environment (not virtual machine)

My env. is Ubuntu 16.04, i5-4670k, 16gb ram and It takes about 1 day for rasbperry pi 3 image with this device.

Hi thanks for reply,
I am not using virtual machine.
I have Ubuntu 14.04 LTS with Core i5-3330 @ 3.00GHz and 8GB RAM

However I think my error is related to python.
I want to know how to set it up. I have python 3.3 .

From your log:

I think you need to install a python 2 instead / as well and then point your path to it

In Ubuntu 14.04, python2 is not installed by default? If it is, python refers to python2, doesn't it?

What does it show when you run this in your terminal?,

which python2

Also, find out what the version of it is.

Hi All thanks for reply,

I have mutiple versions of python - 2.7, 3.3, 3.6 installed.
Is it possible to point to 2.7 only for OSE.
Also where and when to give '--python' option

1 Like

Hi I also faced the same issue while cross-compiling the image for raspberrypi3.

I'm using ubuntu 16.04 in which python3 is default.

So I tried it with 'virtualenv'. for that I followed the following steps:

  1. Install pip first
    sudo apt-get install python3-pip
  2. Then install virtualenv using pip3
    sudo pip3 install virtualenv
  3. Now create a virtual environment with python2.x version.
    virtualenv -p /usr/bin/python2.x venv
    *replace x with your python version or try just python2.
  4. Activate your virtual environment
    source venv/bin/activate

now you will be in the virtual environment "venv".
check the default python version. It must show your selected python version for the virtual env.

After confirming the python version, follow the steps explained in webos website from the beginning.