WebOS prerequisite and make errors (Raspbian-9.4)

First, I would like to thank LG and the community for their work and support of the open source community. This is a FANTASTIC move on their part, and I can’t image the incredible products which might come from this effort.

I think the build documentation is very limited and poorly documented. I’m specifically talking about the Setting Up -> Requirements page found found here. It says that it can only be built on a Raspberry Pi 3, but I can’t find any specifics about Raspbian version and so forth. Even worse, the requirements specifically list Intel i5 dual-core and a minimum of 8GB of memory, which is not possible on the Raspberry Pi.

I have no problem downloading build-webos via git, but I run into a few errors. What version of Raspbian is a supported build platform?

When I run scripts/prerequisites.sh, I get these errors:

E: Package 'gcc-multilib' has no installation candidate
E: Unable to locate package g++-multilib
E: Couldn't find any package by regex 'g++-multilib'

These are apt-get errors, and there is no warning of any problems with the prerequisite script. I don’t know if any of these *-multitab packages are causing my build error, but I seriously doubt it.

When I try to build it using make (not bitbake), I get this error:

WARNING: Host distribution "Raspbian-9.4" has not been validated with this version of the build system; you may possibly experience unexpected failures. It is recommended that you use a tested distribution.
ERROR:  OE-core's config sanity checker detected a potential misconfiguration.
    Either fix the cause of this error or at your own risk disable the checker (see sanity.conf).
    Following is the list of potential problems / advisories:

    Specified SDKMACHINE value is not valid

After doing some additional research, it appears that build-webos is only compatible with Ubuntu 14.04, which appears to be Raspbian Jessie. The lasted build of Raspbian is Stretch, which looks like it’s the same as Ubuntu 16.04. I’m not sure why we have to build this on an older version of Raspbian. I’ll have to attempt this later tonight after I download and boot off a Jessie image.

I’m still looking for other advice to help my build. I couldn’t figure out how to disable the checker in sanity.conf.

After further investigation, it looks like it must be built on a full desktop install of Ubuntu on a PC, not directly on the Pi. I guess I’m so Pi-centric, and almost everything I do is on a Pi, I thought it made sense to build it on the Pi.

I’m now running the cross-platform build on a desktop linux machine and it appears to be building. I don’t see a way to delete this thread. Maybe it will help others who are trying to do the same thing I was.

You can’t build webos on the Pi, but you have to run webos on the Pi.

1 Like


As you investigated, webOS OSE can’t build in Raspbian OS because it uses openembedded build framework (http://www.openembedded.org/wiki/Main_Page).

We officially support Ubuntu 14.04 64bit and it may work in Ubuntu 16.04 64 bit as well.

Built an image on ubuntu server 17.10 64bit. successfully.
Hardware HP Pentium Core2.





Thanks for sharing your experience. I successfully tested on ubuntu 16.04 64bit but webOSE officially supports ubuntu 14.04 64bit in this time.

Did anyone build it with 18.04 ... even if it's not supported?

1 Like

18.04 is not officially supported in OSE now but it will work. We have plan to support ubuntu 18.04 officially.


There's no harm in posting your experience. If you got the wrong idea, somebody else will get the wrong idea too and they may be happier to find that they are not alone.

To build with ubuntu 18.04 please apply these 2 patches.
(fix for compatibility issues with glibc 2.27)