Anyone used Linux virtual machine for building webos-image?

I don't have linux server, so I tried to build webos-image on virtual machine.
But it caused unexpected issues, like refered here in red box..
So, is it only way to build the image using linux server? or did I have another issue?
if anyone built the image in laptop, please give me some advice.

my envi: ubuntu 14.04.5 LTS (virtual machine) && HDD with 100GB

1 Like

Are you trying to build it on the Pi? or on a desktop?

Seems you're missing ICECC, and i'm really curious about "Cannot allocate memory" .. ?

OK, you really edited that message since I replied to it originally :smiley:

Shouldn't be a problem building it on a virtual machine.. but it does seem that you will need to make sure you have all the build dependencies (i think there's a script in the build directory somewhere to do that), including ICECC. And it looks like you might need to have a look at how much memory you have allocated to the VM. You'll probably need at least 8GB to build a complete system.

Oh, thanks to kind answer!
I got different errors when I tried so I thought environment setting is wrong, and changed message :stuck_out_tongue:
Now I checked only 1GB of VM memory, I will set the memory again.


1GB definitely will not work. Last I built the system, I was using a 16GB machine with 32GB swap . . you need a lot of RAM to build Blink. Might be able to get away with 4GB if you have a quite large swap.. but if you can spare the RAM, give it as much as you can, while you're building

1 Like

Absolutely no problem building on a VM here, but it is a very powerful one:

ubuntu 16.04 LTS, 200 GB HDD, 16 CPU cores, 36 GB RAM

(It was my birthday recently! :smiley:)

Thanks to share the information and happy bday!
I think I can retry when the server arrive at my team soon.
I know you because I used your pre-built image usefully :wink::wink:

you can build on virtual machine but need high performance. I recommend that you use high performance machine like over 8 core. Actually I use 32 core machine and 64GB RAM :slight_smile: