Forum

HD TV resolution problem

Hi, how can I set the HDMI output to 720p. All the usual settings in the config.txt file seem to be ignored. All I get is a huge background image with no access to the menu buttons. :face_with_raised_eyebrow:

Will you try to change the resolution? It works for me.
The first way is simple.

1. Change configuration file directly.
a. Connect to target device via ssh

ssh root@192.168.0.5(target device's IP)

b. open configd_db.json in /var/preferences on target device

vi /var/preferences/configd_db.json

c. Modify resolution value of “compositerGeometry” (default value : 1920x1080)

{
    "com.webos.surfacemanager": {
         "compositorGeometry": "1920x1080+0+0r0"
    },
    ...
}

d. Save the file and reboot

2. Set resolution by configd service’s method via luna-send command
a. connect to target device via ssh
ssh root@192.168.0.5(target device's IP)

b. Check current resolution. Put the below command :
luna-send -f -i palm://com.webos.service.config/getConfigs '{"configNames":"com.webos.surfacemanager.compositorGeometry"]}'

response :

{    
       "subscribed": false,
        "configs": {
        "com.webos.surfacemanager.compositorGeometry": "1920x1080+0+0r0"
    },
    "returnValue": true
}

c. Change resolution. Put the below command :
luna-send -n 1 -f luna://com.webos.service.config/setConfigs '{ "configs":{"com.webos.surfacemanager.compositorGeometry": "1280x720+0+0r0"}}'

response:

{
    "returnValue": true
}

d. reboot

If anyone knows the better way to change resolution, please share :slight_smile:

Hi, can you be a bit clearer what the actual commands are?

I updated. The way(#1. Change configuration file) is simple.
Please refer to http://webosose.org/develop/ls2-api/ls2-api-development/ and http://webosose.org/develop/ls2-api/ls2-api-reference/com-webos-service-config/

Doesn’t work, all i get is this -

root@raspberrypi3:~# luna-send -f -i palm://com.webos.service.config/getConfigs’{“configNames”:[“com.webos.surfacemanager.compositorGeometry”]}’
luna-send uri message
-h this help screen
-P send over the public bus (deprecated, has no effect)
-s send a signal
-a send specified appId in message (default is none)
-m service name (default is none)
-d turn debug logging on
-i turn on interactive mode
-t x average over x times getting one response
-n x exit interactive mode after x replies
-l number responses
-f format JSON responses usefully
-q apply specific query to responses (multiple queries may be supplied), e.g.:
-q ‘returnValue’ -q ‘queues[0]’
-w x Set exit timeout value to be ‘x’ milliseconds

The command should be in one line. Could you try again?
You can get current config value with getConfigs and change the value with setConfigs.

luna-send -f -i palm://com.webos.service.config/getConfigs '{"configNames":["com.webos.surfacemanager.compositorGeometry"]}'

luna-send -n 1 -f luna://com.webos.service.config/setConfigs '{"configs":{"com.webos.surfacemanager.compositorGeometry": "1280x720+0+0r0"}}'

Also, you can try modify configd_db.json in /var/preferences on target device.

still no luck, now all I get is >

root@raspberrypi3:~# luna-send -n 1 -f luna://com.webos.service.config/setConfigs ‘{ "configs”:{“com.webos.surfacemanager.compositorGeometry”: “1280x720+0+0r0”}}’

Could you please put the command on terminal manually?(Do not copy and paste.)

Why don’t you try modify configd_db.json in /var/preferences on target device?

Tried this but it keeps getting reset to the default values after reboot.
None of these solutions work :confused:

I adjusted the resolution in two ways… I’m sorry I can not help you. :sob:

I think its an issue with the TV. Thanks for your help.

I tried to do below command in my official raspberrypi3 touch screen (800x480) and below command works. After running below command, you should reboot.

luna-send -n 1 -f luna://com.webos.service.config/setConfigs ‘{ "configs”:{“com.webos.surfacemanager.compositorGeometry”: “800x480+0+0r0”}}’

FYI
official raspberrypi3 touch screen is not supported yet. I add some features in my local.

1 Like

Fixed! :grinning: It was a keyboard input problem with the 's and the "s. for some reason they were being changed as I typed, could be the japanese keyboard i’m using.

Guys, i have the similar problem. However, additionally, my raspberry only has wifi access. hence, ssh’ing is difficult.
Therefore, i was wondering. Is there a command that cancels the entry to the GUI. If i stay in the prompt, i can manually alter the resolution command.
thanks!
best,
hans

I am glad that your problem has been resolved. :slight_smile:

If you have serial cable for raspberry pi 3, you can use console without network setting.
https://developer.android.com/things/hardware/raspberrypi.html

Thanks. I found a solution in the end.
I manually changed the resolution and now works like a charm!

Can i set a custom refrash rate?

hi, Changhyeok, could you share what you had done in your local?
I had tried what you said to make my officail raspberrypi3 work with webos, but failed. I can boot the raspberrypi, but the touch screen only showed part of the content. I can not make all the content shown in the screen.

1 Like

@wistoch Which touch screen do you use? RPI official 7inch touch screen or others? Then what's your touch screen resolution?

1 Like