How to get Netflix working on WebOS?

Hi everyone,

I am Newbie here. Sorry for being noob. Just wanna asking.

I can login into netflix but cannot getting netflix working properly. It was lagging (sound). I do not know which one is related, DRM or HW on raspi 2.

I tried copy & paste this files (”, “”, “”) into folder "/usr/lib/chromium/" && "/lib/chromium/".. But still not working.


Demo video

1 Like

@suaji Your work (I saw your demo video) looks good. I'm worry that we don't support netflix at this time. Could you share how to work netflix? Then I can check it with development team.

The netflix application is just redirection in webapp? and which version do you use? Now we released build #17.

Thanks for replying sir.. It is just redirection from index.html

window.location = ""

May i know sir what did u mean, "Now we released build #17."

1 Like

Our latest version is webos-image: Update layer pins for 2018-08-13 (build 17) · webosose/build-webos@d6c1d92 · GitHub (build #17). Which version do you use for your netflix test?

T..T forgive me sir. I am totally noob. Hahaha. I just found img file and flash it. I dont compiled my self. I dont have super-duper computer and ssd.

Can i check it in settings or ssh if i wanna know which version i used it?.. if can, how to check it with ssh?

Where did you get the Netflix app? I am getting interested.

Hi @yisooan,
I believe @suaji has mentioned that it's a redirection to the Netflix homepage from index.html.

1 Like

there is no app.. It is just small edit from noob like me :joy::joy::joy:

edit json and html files..
( /usr/palm/applications )

Or you free to download and copy & paste too..
Here is download link, Netflix

  1. Download and Extract file
  2. Place your webos sdcard to any ubuntu pc
  3. login as Root @ sudo nautilus
  4. copy folder "" into (/usr/palm/applications)
  • i dont know how to convert to ipk files and transfer using SSH..

Forgive me ^_^v

1 Like

I have faced the lagging of sound problem in Youtube app as well. So far I have been watching Youtube channels. It happens from time to time when I watch HD 720p videos on Raspberry Pi 3 with remote controlling in my smartphone which Youtube supports and move the timeline/the playbar back and forth.

Hi @yisooan,

Is the issue coming up only when watching at 720p?
In which case I assume it could be the hardware struggling with the high resolution and not exactly an issue with webOS.

Are we close to get netflix working?.

Because in version 20180925122909, Netflix trailer replay no more lagging compare to version 20180320005655 (First video above).

Here is youtube video
Net-Flix WebOS Raspi 2

  • i tried to manual install Chromium browser but still not working :joy::joy::joy:

I dont know WEBOS OSE based on what linux, what distro, what kernel. So cant try to install using dpkg.

I just extract (7zip) chromium.deb armhf version, COPY PASTE into folder :




** I Really LOVE WEBOS then KODI. It was simple and fast. I just need Live TV and Netflix only. I dont care about addons just like in kodi :wink:

*** sorry for noob english ^_^v

Hi @suaji, a couple of things I noticed.

webOS is definitely based on Linux but I don't think it has any involvement with a distro. It's similar to how Android is based on Linux but is not called a distro. I don't have an idea about the version of Linux although that won't become a problem in most cases.

Did you try to manually install a .deb file into webOS?
I'm not exactly sure (maybe one of the devs can chip in here if I'm wrong) but I don't think you can install .deb files as in a traditional Linux distro. From what we can understand from the docs webOS only supports webapp and QML apps in the built in the .ipk package.

Nothing to be sorry for, your english is perfectly clear and understandable. :slight_smile:

1 Like

Yes i did with dpkg. not working. that is why asking webos based on what linux. i can try again to install in another way.

That is why too, i tried to manual extract .deb and copy paste into linux folder.

Hmmm. I wish i know linux very well so i can launch chromium browser and watching netflix T..T

** May i know i we cant ported @ fork Netflix app from LG WebOS TV?..

*** What is diffrent between this webose and LG WebOS TV?.. just version 3.5 and 4.0 above??

I mentioned this earlier, I dont think it is possible to launch traditional Linux apps on webOS. Let me repeat that; webOS is NOT Linux.
webOS is a separate operating system that shares a Linux kernel at a very low level. This does not mean traditional .deb files can be installed on webOS. That's not how it works.

The Netflix app isn't open source and consists of their proprietary APIs and libraries. I don't know from which repo you are planning to fork from but I don't know of any that's available.

Visually I think the biggest difference between webOS OSE and webOS TV is the lack of the card-based GUI that's seen on LG smart TVs.
From what I understand OSE is also optimized to work on the Raspberry Pi platform compared to the regular webOS which runs on the ARM processors in LG smart TVs. There may be many other changes under the hood, but I honestly don't know that in-depth.

Hi, @suaji and @n-jay

I added some comments for your information.
webOS OSE is based on OpenEmbedded Yocto Linux 2.2(Morty) using raspberrypi linux kernel 4.4.y
And, Netfix app for LG webOS TV is ported on NRDP not HTML5 but Native app.

@suaji, I have one question about your Netflix demo on YouTube. Is it possible to play DRMed contents. A trailer is clean video but full video clip is DRMed stream. Can you see a full video clip ? Let us know a resolution of stream video If you possible.

I would like to see some more apps such as Netflix, Amazon Prime Video using HTML5 MSE/EME and Widevine CDM those are the most interesting and attracted to me and a lot of people. :grinning:


Hi @hyunsung

Wow, that's quite interesting. I never knew that the platform developer had to port the Netflix app themselves. That's quite insightful, thank you for the clarification. :smiley:
Speaking of which; by Native do you mean a QML app? I don't suppose it's Open Source and the .ipk is freely available by any chance.

Additionally, I think it would be best if you could elaborate on whether traditional Linux apps(.deb, .AppImage etc) can be installed on webOS as inquired by @suaji.

1 Like

webOS is a Linux system (see above), but installation of dependencies to the system is a problem. You're not going to be able to directly install a .deb or something into it, though, as you don't have the necessary package management software. As well, you're probably not going to find too many native ARM binaries for things, that play well with Wayland as a compositor. Any software that does meet those requirements, though, you should be able to build using the build system (oe), and could install it directly to the system that way.


Hi, @n-jay

I found an article about the Netflix for tv. Netflix wanted to deliver a richer experience on TV with SDK than HTML5. I posted on netflix-techblog link


Not working huhu..

I tried netflix, iflix and spotify. I did not try Amazon Prime because i dont have id.. Sorry sir..

Btw, thanks for your explanation above ^_^v

Hi jay..

For your info, i tried to extract Chromium.rpm too.
It will show you Same Folder and ALMOST Same files in Chromium.deb

etc->chromium (rpm)
etc->chromium-browser (deb)
etc->default (both)

usr->bin (both)
usr->lib (both)
usr->share (both)

If chromium portable in windows, we can open with just click chromium.exe.

Can we just manual install (same as in windows app portable), and open that file?.
If can, then we can set auto run startup Chromium App in linux service (systemctl)..
If succes, we can do the next step, how to Link @ Enable DRM..

hehehe sorry just logic thinking ^_^v (peace)
I dont know how to explain. I cant speak english very well