Forum

Issue while installing application on raspberry pi 4

I am trying to install the application to my raspberry pi 4 which has WebOS. Unfortunately, the process is not being completed. Can anyone help me solve this issue?
When I run the command, the status shows:
"Installing package /home/rahul/com.domain.app_1.0.0_all.ipk", I also tried waiting for more than 30 minutes, but the process never gets completed.

1st Try to make sure below sample webapp template is working with below steps

ares-generate -t webapp -p "{'id':'com.domain.app', 'version':'1.0.0', 'title':'new test app'}" ./webapp
ares-package webapp
ares-install --device pi com.domain.app_1.0.0_all.ipk
ares-launch --device pi com.domain.app

In case installation is failed with above step, then could you please update the OSE CLI and try same again the same steps.
In case if above steps are working, try to install with your IPK. And if still issue exists then please share the jounald logs.
(refer to below post on how to capture journal log in device terminal)