Forum

Raspberry Pie 4 can't install apps using ares-install command

I tried to install a new app using the ares-install command on webos installed on Raspberry Pie 4, but it didn't install without a success message. The installation command or method was the same as when Raspberry Pie 3 was used, and the success message appeared on Raspberry Pie 3 and the app was successfully installed, but it did not work on Raspberry Pie 4. Is there a solution?

Current latest version of webOS OSE is supported on RasberryPi4 and its been officially tested.
To understand your issue, could you please provide more details like error displayed(with screenshot, journal logs) when you tried to execute ares-install ?


I used latest version, but couldn't install any app...
There is no success message....

After a long wait, I shut down the terminal and turned Raspberry Pi 4 back on, and the app was installed. When I was using Raspberry Pie 3, I got a quick success message but I don't know why this is happening in Raspberry Pie 4.

actually i have also faced same issue but its gone after the update.. .

@ANIAN_ahn Can you update the OSE CLI and try again. If you are facing the same issue. Please share the jounald logs.
(refer to below post on how to capture journal log in device terminal)

Can you try this code?

ares-generate -t webapp -p "{'id':'com.domain.app', 'version':'1.0.0', 'title':'Test App'}" ./webapp
ares-package webapp
ares-install com.domain.app_1.0.0_all.ipk

If it works, There is no error in ares-install command.

As far as we have been informed, this issue occurs only in Raspberry Pie 4 8GB model. The development team is currently checking.

It may be too late but I'll tell you what I know.

Maybe you are using webOS devel version.
You should install normal version webOS in your rpi4